Azure Stack RTM PoC Deployment stops @ Step 60.120.121 – deploy identity provider

Hello Community,

some of you maybe encountered following issue during the deployment of the Azure Stack RTM PoC.

Lets look on the field configuration:

  1. One server HP DL360 G8
  2. NIC Type 1GBE Intel i360 (HP OEM Label)
  3. Two Public IPv4 Adresses published directly to the host and host configured as exposed host in the border gateway firewalls
  4. No Firewall Rules for that host on the gateways
  5. Switchports for that host configured as Trunk/Uplink ports with VLAN tagging enabled
  6. We use Azure AD for Authentication

In my case, the important point is the port trunk and the VLAN tagging.

Normally VLAN tagging is no issue because the deployment toolkit should set the tag automatically during deployment for all VMs required and the host system.

In my case and during many test and validation deployments, that didn’t happen. After I start the deployment, a new virtual switch will be deployed and a virtual NIC named “deployment” will be configured for the host. Afterwards the deployment starts. Around 3 hours later, the deployment stops in step 60.120.121 and could not connect to the identity provider.

Whats the reason for the failure?

First you should know, that the Azure Stack Deployment switches between host and BGPNAT VM for internet communication. Mostly all traffic runs through the NAT VM but in that case, the host communicates directly with the internet.

So what happend? After creating the “deployment” NIC for the host, the deployment tool didn’t set the VLAN Tag on that virtual NIC. That breaks the network communication for the host, for the VMs there isn’t any issue because the VLAN is set for the NAT VM correctly.

What is the Workaround?

  1. Start the deployment and configure it like normal
  2. Let the deployment run into the failure
  3. Open a new PowerShell with admin permissions (Run as Administrator)
  4. Type in following Command:
  5. Rerun the deployment with

    From the installation folder.

Afterwards the deployment runs smoothly.

 

Please be aware, after the installation, the VLAN ID is removed again. So you need to set it one more time. 

Tagged , , , , , . Bookmark the permalink.

2 Responses to Azure Stack RTM PoC Deployment stops @ Step 60.120.121 – deploy identity provider

  1. MT says:

    You saved the day.

Leave a Reply

Your email address will not be published. Required fields are marked *